Welchen Webserver nutzt ihr?

  • Ich habe wie wahrscheinlich fast jeder mit Apache angefangen, da der mir aber zu langsam war und für 3-4 Webseiten total überdimensioniert ist bin ich irgendwann auf Lighttpd umgestiegen und war damit auch lange sehr zufrieden.

    Dann habe ich irgendwann Caddy entdeckt und habe den mal ausprobiert. Caddy hat einige sehr überzeugende Features wie HTTP2 und automatisches SSL über LetsEncrypt.

  • Ich habe damals für den Anfang Apache2 verwendet, was der guten Doku geschuldet war.


    Danach rückte nginx in den Vordergrund, weil ich es mit LibreSSL verknüpfen konnte.


    Heute bin ich bei Caddy, und bin sowohl mit der Performance absolut zufrieden. Die liegt so bei 80-90% ausgegangen von nginx. Außerdem enorm ressourcensparend und die Möglichkeit Google's "QUIC" Protokoll zu verwenden (Also HTTP+TLS über UDP) lassen Caddy echt herausstechen.


    Lasse mehrere Domains bei mir laufen und kann dementsprechend auch automatisch TLS Zertifikate ausstellen und erneuern lassen.:thumbup:

  • und die Möglichkeit Google's "QUIC" Protokoll zu verwenden

    Nett, kannte ich noch gar nicht. Aber irgendwie läuft das bei mir nicht, auch wenn ich Caddy mit "-quic" starte zeigt mir Chrome nicht an dass Quic verwendet wird. Bei google.de funktioniert es, mein Browser kann das also.


    Edit:

    Komisch, bei manchen Seiten funktioniert es, bei anderen nicht, habe aber keine Unterschiede in der Config gefunden.

  • Aber irgendwie läuft das bei mir nicht

    Die könnte daran liegen, dass Chrome die QUIC Versionen sehr häufig aktualisiert und die Kompatibilität für die Ausläuferversionen schnell eintellt.


    Heißt: Am besten die neuste Version (aktuell: 0.11.12) verwenden, wo QUICv39 verwendet wird. Das ist auch die, die derzeit Chrome und sogar Chrome Beta verwenden.


    Evtl. auch zukünftlich Firefox, allerdings arbeitet gerade auch eine Working Group an der Standardisierung von Google's QUIC Protokoll, so dass es vermutlich demnächst eine IETF (IQUIC) und eine Google (GQUIC) Version geben wird.

  • Komischerweise hat es nach einiger Zeit dann ohne das ich was getan habe funktioniert. Hatte zwar den Cache ausgeschaltet und die Seite mehrfach neu geladen, irgendwann zeigte mein Chrome Plugin dann QUICK an ohne das ich nochmal was geändert habe. Jetzt muss ich nur noch schauen wie ich Server Push richtig einsetze, das CSS immer pushen ist ja irgendwie blöd und ein Cookie deshalb setzen möchte ich auch nicht. Aber meine Seite ist so auch schon recht schnell also lasse ich das alles mal so.